A/C not cooling

posted by Altima

Experts need your help please .My altima sedan a/c was not cooling at all but blower was working .So ,mechanic said clutch "coil " was damaged & thus "repaired " the coil
& the ac was cooling .Not that good cooling but at least cooling somewhat .Now again within 15 days its not cooling completely .Can you please tell me what to check or where or what could it be .Im asking experts since mechanics might just say compressor is bad etc .please suggest any good mechanic or any specific place .

Like 0   DisLike 1
Posted On 8/16/2017 3:57:58 AM by shuweikh

Check AC gas . may be very low. Refill it to 90% ( not full).
Don't run the compressor if AC gas is nil. Compressor will get damaged.

Posted On 8/16/2017 11:09:55 PM by Altima

Thank you very much shuweikh .I just refilled the gas yesterday and its cooling well now .But im worried it may just work for a short while .
Do you think again after sometime if the cooling drops ,there could be a leakage or some other problem ?

Posted On 8/17/2017 12:09:25 AM by shuweikh

If the car is very old and if AC tubing has been meddled by untrained mechanics then there are chances of slight leak some where in tubing or connecting points. since you have filled the gas check for few days and see if there is any change in cooling (ie lower cooling than now). Also check the cooling difference during noon and night at different cool settings.
btw i am not an expert just giving the info as i know from my previous experience.

Posted On 8/17/2017 12:59:54 AM by shuweikh

chk this video for general guidance

https://www.youtube.com/watch?v=iuTK6wCTEzg

Posted On 8/17/2017 1:31:55 AM by Altima

Thank you shuweikh once again .The car is little old 2009 .As you said ill wait n check after few days .maybe the mechanics did something when replacing the clutch coil .So hopefully ,I dont think there is any problem with the ac clutch assembly or compressor since its working nw ,mostly should be a leakage .

Posted On 9/9/2017 12:19:34 AM by Altima

The cooling has completely reduced again within around 20 days .What do you suggest ? Is it a leakage .Where can i check for leakage sharq / shuwaikh .Do you know around how much do they charge for this check and how is it done .

Posted On 9/9/2017 11:30:56 PM by Altima

I have filled the gas again along with the neon fluorescent liquid which
detects where the leakage takes place .

Disclaimer
All the content posted under the 'IIK Forum' are made by the readers of IndiansinKuwait.com, unless specified otherwise. IndiansinKuwait.com is not responsible for the opinions of the readers and the content posted by the readers are not representative of the views and opinions of IndiansinKuwait.com. IndiansinKuwait.com takes no responsibility for the views expressed in the discussion.
Posting complaints with name/address changed or anonymously not allowed. Those accounts will be banned.
No complaints may be posted while impersonating (acting as a different person).
For any complaints about any person, business establishment or an entity, you must leave your verifiable contactable address & phone number otherwise your post will be deleted. 
Forum does not allow you to post defamatory / malicious post against any person or an entity.
Topics of nature related to disrespectfully criticize, impersonate, include personal details of, make false/malicious claims about; or negatively affect any member,  person or entity will be removed We appreciate your help in keeping IIK Forum clean and a pleasant experience for our readers. Search the forum before you start a new discussion to avoid repeating debates.

Frequently read topics...

How to start a topic for discussion?
Its easy! Click here to post your topic.
You need to login, if you are not already logged into IIK. If you are not yet a member, you can register here.
How to read and reply an existing topic?
You can view an existing discussion by clicking on that topic title. When you are in a discussion, you can share you reviews and opinions by clicking on the REPLY button on that page.